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Welcome to CenoPDF 

CenoPDF is a Microsoft Office add-in. It is the first product on the market that allows users to directly edit, save and create PDF and 
its annotations from within Microsoft Word or Microsoft Publisher. Users can generate final PDF files with all the annotations and 
form fields at any time by just a few clicks on the Office tool bar. 

Installing CenoPDF 

CenoPDF installation file includes Microsoft .NET Framework. If the installer detects your computer does not have Microsoft .NET 
Framework, it will install it automatically for you.   

You also need Microsoft Office and its latest service pack installed. You can visit Microsoft Office Download Page to install the 
necessary service pack.  

You can always download the latest version of CenoPDF from http://www.lystech.com/download-pdf-form-tool.aspx . The 
installation file is CenoPDFInstall.exe. Run this file and follow the instructions to complete the installation. 

See also 
General troubleshooting steps 

Uninstalling CenoPDF 

To uninstall CenoPDF, you can go to Add or Remove Programs in Control Panel. Click CenoPDF and Remove button.  

Or 

You can go to Start menu on your desktop and choose All Programs > CenoPDF > Uninstall CenoPDF. 

Installing on Terminal Server 

CenoPDF can be installed on Microsoft Servers with terminal service so that all clients can share the single copy of the software. 

Warning: You must obtain a CenoPDF license for each single user that uses the software. Otherwise, you will violate the License 
Agreement. 

To enable CenoPDF running in a terminal client, you must install additional novaPDF Professional Server (novapsv.exe), which could 
be downloaded from our web site, separately on the server. Here are the steps to install: 

1. Log on the Terminal Server as an administrator. 

2. Run command: change user /install 

3. Run CenoPDFInstall.exe to install CenoPDF 

4. Run novapsv.exe to install novaPDF Server Edition 

5. Run command: change user /execute 

  

  

Getting help with CenoPDF 

If you need more information about using the program, a few resources are available to you. Here are a few options: 

 View the online Help 

 If you have any questions, email us at support@lystech.com. We are more than happy to assist you.  

 Check the FAQ section in our web site 

  

http://office.microsoft.com/en-us/downloads/maincatalog.aspx
http://www.lystech.com/download-pdf-form-tool.aspx
mailto:support@lystech.com
http://www.lystech.com/faq.aspx
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Using CenoPDF's online help 

You can use any of the following ways to access CenoPDF's context-sensitive online help system:  

 Press F1 key on any CenoPDF dialog box to show the help on the subject  

 From Microsoft Word or Microsoft Publisher, choose the menu CenoPDF > Help 

 From Windows desktop, choose start > All Programs > CenoPDF > CenoPDF Help 

  

Launching CenoPDF 

CenoPDF is not a standalone application. You can either launch Microsoft Word or Microsoft Publisher, which automatically loads 
CenoPDF as an add-in. If CenoPDF is installed successfully, you should see the CenoPDF menu and tool bar in above applications. 

This walkthrough demonstrates how to create a basic PDF form. 

See also 
Troubleshooting CenoPDF failed to start up 

Basic steps to create a fillable PDF form 

This walkthrough demonstrates the process to create a PDF file using CenoPDF. In this walkthrough, you will create a Microsoft 
Word document, add some PDF form fields and generate the final PDF file. 

The files created by this walkthrough can be downloaded here: walkthrough.doc and walkthrough.pdf. 

1. Launch Microsoft Word. The CenoPDF menu and tool bar will appear in the window if it is installed properly. Start with a 
blank document. Zoom the page to 100%. 

file:///C:\Luyang\OfficePdfAddinHelp\Content\create-pdf-form-in-microsoft-office-word\walkthrough.doc
file:///C:\Luyang\OfficePdfAddinHelp\Content\create-pdf-form-in-microsoft-office-word\walkthrough.pdf
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In Microsoft Word 2007 Fluent user interface, CenoPDFtab is in the Ribbon: 

 

2. Choose Table > Insert > Table to insert a table in the document. Type Applicant Name:, Job:, Manager and Developer in 
the table cells. 
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3. Choose CenoPDF > Add Text Box. 
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4. Text Box Properties dialog box pops up. Type appname in the Name box. Click the OK button. 
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5. A new box, which represents the PDF text box you just added, appears in the document. Drag it to the cell next to the 
Applicant Name. Adjust the table and the text box as you like. 
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6. Choose CenoPDF > Add Radio Button. 
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7. Radio Button Properties dialog box pops up. Type job in the Name box. Click Options tab. Type manager in the 
Export Value box. Click the OK button. 
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8. A new box, which represents the PDF radio button you just added, appears in the document. Drag it to the right side of the 
text Manager. 
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9. Add another radio button. In the Radio Button Properties dialog box, type job in the Name box. Click Options tab. 
Type developer in the Export Value box. Click the OK button. 

Note that the two radio buttons with the same name will be grouped together and only one of them can be checked at any 
given time. 
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10. Drag the added gray box to the right side of the text Developer. 
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11. Choose CenoPDF > Export to PDF. 

Important: You must always use the command CenoPDF > Export to PDF to generate PDF files in CenoPDF. Your 
computer may have other PDF software installed and have various ways to generate PDF files, but this is the only way that 
CenoPDF uses. 
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12. Type demo in the File name box and click the Save button. 
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13. When the export is finished, you will see the success message. If you have installed a PDF viewer program such as Adobe 
Reader, you can click the Yes button to open the newly generated PDF file in the viewer. 

http://www.adobe.com/
http://www.adobe.com/
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14. This is how the PDF file looks when opened in Adobe Reader. 
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PDF field type 

You can add various types of PDF fields to your document. Here is the introduction of the purpose of each type of fields. 

Field Type Description 

Text box 
Text boxes are the most commonly used PDF fields. They allow your users to enter texts in the fields 
when the PDF document is opened by a viewer program. You can set the display format as currency, 
date, phone number, etc. 

See also 
Formatting text box 
Restricting characters in a text box 
Text Box Properties dialog box 

Check box 
A check box has two states - checked or unchecked. When a check box is displayed in a PDF viewer, 
users can click on it to change its state. When it is checked, a check mark is displayed. Check boxes 
are commonly used to present a yes/no condition. 

See also 
Using check box 
Check Box Properties dialog box 

Radio button 
Radio buttons are usually used as a group. Radio buttons that shares the same name are in the 
same group. PDF viewer makes sure that only one radio button can be checked at any time. Radio 
buttons are used to present the condition that only one item can be chosen among a few items. 

See also 
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Field Type Description 

Grouping radio buttons 
Radio Button Properties dialog box 

List box 
A list box is used to display a list of items in a box. Users can select one or many items from a list 
box. 

See also 
List Box Properties dialog box 

Combo box 
A combo box is a combination of a text box and a drop-down list box. When a PDF viewer renders a 
combo box, usually the drop-down list box is not displayed at the beginning. Thus the combo box 
behaves as a text box at the beginning. At the right side of the text box, there is a button. When 
user clicks that button, the drop-down list box pops up and the user can select an item from the list. 

See also 
Combo Box Properties dialog box 

Push button 
Push buttons are usually used to perform some actions. 

See also 
Push Button Properties dialog box 

Signature box 
Signature boxes are used to allow end users to input digital signature. For more information please 
see Adobe Acrobat documents. 

Note: One of the following two conditions must be met in order to allow your end users to use a 
signature box to sign and save a document. 1) Your end users have Adobe Acrobat; or 2) You, the 
author, have Adobe Acrobat 8 or higher and used Enable Usage Right in Adobe Reader 
command on the CenoPDF-generated PDF. 

See also 
Signature Box Properties dialog box 

Free Text 
Free Text fields are used to display static texts on the document. 

See also 
Free Text Properties dialog box 

Link 
Links are used to perform some actions when users click on it. The major difference between links 
and push buttons is that links does not have caption and it displays transparently on the document.  

See also 
Using hyperlink 
Link Properties dialog box 

Markup 
A markup can highlight, underline, strike out, etc the texts underneath it. You can also supply a note 
for the markup. When users double-click the markup, the note will pop up. 

See also 
Markup Properties dialog box 
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Field Type Description 

Note 
You can choose an icon for a note. When a PDF viewer displays a note, the icon will be displayed 
initially. If users double-click the icon, the note will pop up. 

See also 
Note Properties dialog box 

Square or circle 
This field draws a square or circle shape on when a PDF viewer displays it. You can also set a note 
for the shape. If users double-click the shape, the note will pop up. 

See also 
Square Shape Properties dialog box 

CenoPDF commands 

After CenoPDF is successfully installed, its menu and tool bar will appear in the supported Microsoft Office products. When you 
hover your mouse on any button on the CenoPDF tool bar, a tool tip window will pop up with a brief description for the button. 

Command Description 

Add Text Box Adds a PDF text box in the active document. 

Add Check Box Adds a PDF check box in the active document. 

Add Radio 
Button 

Adds a PDF radio button in the active document. 

Add List Box Adds a PDF list box in the active document. 

Add Combo 
Box 

Adds a PDF combo box in the active document. 

Add Push 
Button 

Adds a PDF push button in the active document. 

Add Signature Adds a PDF signature box in the active document. 

Add Free Text Adds a PDF free text annotation in the active document. 

Add Ink Adds a PDF ink annotation in the active document. 

Add Line Adds a PDF line annotation in the active document. 

Add Link Adds a PDF link annotation in the active document. 

Add Markup Adds a PDF markup annotation in the active document. 

Add Note Adds a PDF notes annotation in the active document. 

Add Rubber 
Stamp 

Adds a PDF rubber stamp annotation in the active document. 

Add Square or 
Circle 

Adds a PDF square or circle shape annotation in the active document. 

Add Page 
Settings 

Adds a PDF page settings box in the active document. The page settings box looks similar to the other annotation 
boxes, but there could be only one page settings box for any given page. It serves as a container where user can 
define the page setting information for a page in the final PDF file. It can be positioned anywhere in the document 
and will not appear in the final PDF file. Once exported to the PDF file, the settings will be rendered to the 
corresponding PDF pages. 
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Command Description 

Document 
Settings 

Displays the properties of the active document. 

Field Properties Displays the Field Properties dialog box for the selected field in the active document. 

Field Manager Displays the Fields Manager dialog box for the active document. You can modify or locate any field from this 
dialog box. 

Options Displays global software and PDF settings that will be applied to all documents. 

Export to PDF Exports the active document to generate a PDF file. 

Export to PDF 
from Database 

Uses a database or Excel spreadsheet to populate the fields on the active document before exporting to PDF files. 

Check for 
Update 

Connects to the server to check if there is any new version of the program available. 

Help Displays the online help. 

About CenoPDF Displays the software version, copyright and registration code box. 

General workflow 

Important: You must always use the command CenoPDF > Export to PDF to generate PDF files in CenoPDF. Your computer 
may have other PDF software installed and have various ways to generate PDF files, but this is the only way that CenoPDF uses. 

CenoPDF greatly simplifies the process to generate high quality PDF files. The steps are as easy as follows: 

1. Create a document in Microsoft Word or Microsoft Publisher with standard document elements such as texts, paragraphs, 
images, tables etc.  

2. Use CenoPDF menu to add PDF form fields, annotations, page settings, document settings etc.  

3. Use Export to PDF from the CenoPDF menu to export the document to a final PDF file. 

4. Save the document as needed. All PDF elements will be saved in the same Word .doc file or Publisher .pub file.  

See also 
Basic steps to create a fillable PDF form 

Editing field properties 

Here are the ways to access the Field Properties dialog box:  

 When a field is added, its properties dialog box pops up automatically.  

 Right click on a field. From the context menu, choose PDF Field Object > PDF Properties 
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 Select one or more fields (you can hold the Ctrl key and click on fields to do multiple selection). From the CenoPDF menu, 
choose Field Properties. 
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 From the CenoPDF menu, choose Field Manager. In the dialog box, select one or more fields. From the Edit menu, 
choose Properties.  

 Multiple selection allows you to change the properties of selected fields all at once. 

Changing field default settings 

You can change the default settings for new PDF fields that added to a document. From the CenoPDF menu, choose Options > 
Defaults. Select a field type you want to change, then click Change Default Settings button. 

After you change the settings, CenoPDF will use your new settings to add fields. 

Adjusting field position 

Normally, if you drag a field or any floating object in a Microsoft Word document, Word will constrain the location of the object to 
an invisible grid. 

 If you want to drag a field without the constraint, you can hold Alt key while dragging. 

 If you want to precisely set a field position, you can right click on the field and choose Properties from the context menu. 
Change the position in the Properties window as the screenshot below.  

Warning: you shall never change the Name in the Properties window. 
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Finding a field 

You can find a specific PDF field in a document using Field Manager. The steps are:  

1. From the CenoPDF menu, choose Field Manager. 

2. In the field list, double click on the field of interest. This will directly bring you to the field on the document. 

Format text box by property settings 

A text box or an editable combo box can be formatted to display number, currency, date, time, zip code, phone number, social 
security number, etc. This tutorial demonstrates how to create a text box and display its contents in currency format. A more 
advanced way that uses JavaScript to format PDF text boxes can be found here . 

1. Launch Microsoft Word. Choose Add Text Box from CenoPDF menu. In the Text Box Properties dialog box, click 
Format tab. 

2. Choose Number or Currency from Format the field as box; Type 2 into Number of digits after decimal point box; 
Type $ into Currency Symbol box. 
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3. Export to PDF file and open it in Adobe Reader. Type 12 into the text box and press Enter. A dollar sign and two decimal 
digits are automatically added into display. 
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Submitting form data via email using Email Form Data action 

This walkthrough demonstrates how to submit form field data via email using Email Form Data action. If you need more control 
and flexibility, you can use JavaScript to do the similar thing. This walkthrough has been tested with Adobe Reader 8 and Microsoft 
Outlook 2007. 

1. Launch Microsoft Word. Add three text boxes by choosing Add Text Box on CenoPDF menu. Set the name of those text 
boxes to FirstName, LastName and Comments as the following screen shot.  

 

2. Choose Add Push Button on CenoPDF menu. In the Push Button Properties dialog box, click Options tab. Set the 
normal button text as Send Email.  
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3. Click the Actions tab, the Mouse Up trigger and the Add button. 

4. Choose Action Type as Email Form Data. Type recipient email address in the To box, for example, 
test@mycompany.com. Type From [[FirstName]] in the Subject box. Type the following into the Message box. 

First name: [[FirstName]] 
Last name: [[LastName]] 
This is my comments: [[Comments]]  

Click the OK button. 

[[FirstName]] means use contents of the field FirstName. The field names are case-sensitive and the name here must 
exactly match the one in field property settings. 
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5. Choose Export to PDF from the CenoPDF menu to create the PDF file. Open it in Adobe Reader. Fill all fields. 



CenoPDF User's Manual Lystech Computing 

  http://www.lystech.com 

27 

 

6. Click the Send Email button. The email client, Microsoft Outlook in our example, pops up with the contents we just 
created from the PDF file. 
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Note: This step uses Messaging Application Programming Interface (MAPI) in your computer to open Microsoft Outlook. 
MAPI is a messaging architecture that allows clients (Adobe Reader) to interact with email program. In most cases, MAPI is 
set up automatically after an email program, such as Microsoft Outlook, is installed. In very rare cases, however, if your 
user's computer does not have MAPI or it is not configured correctly, it is always a good idea for you to provide alternative 
ways, such as fax, to send information back. 

Test MAPI: Go to Windows Explorer, right click on any file and choose Send To > Mail Recipient from the context 
menu. If your email client opens, your MAPI is OK. Otherwise, if your email client does not open, your MAPI is probably 
not set up correctly and this step may not work either. 

Submitting data via email, then importing into Excel 

In this walkthrough, we continue to use the sample in Submitting form data via email using Email Form Data action but with some 
changes in the email format, so that after the email is received, we can import the data into an Excel spreadsheet. 

1. Launch Microsoft Word. Open the file that created in Submitting form data via email using Email Form Data action . There 
are three fields, FirstName, LastName and Comments, in this file.  

2. Go to the Email Form Data action that we have created for the Send Email button.  

3. Clear the Message box.  

4. Click the Insert Field Names button. In the coming dialog box, check all field names and click OK button. 

 

5. The Message box is automatically filled with bar-separated fields. If you do not want to use the Insert Field Names 
button as a shortcut, alternatively you can type the texts here, which has the same effect. Click OK button a few times to 
close all dialog boxes. 



CenoPDF User's Manual Lystech Computing 

  http://www.lystech.com 

29 

 

6. Choose CenoPDF > Export to PDF to create the PDF file. Open it in Adobe Reader. Fill in the fields and, then the Send 
Email button. The email client, Microsoft Outlook in our example, pops up with the contents of the fields separated by 
bars. Send out the email. 
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7. The recipient receives the email. Highlight the email. Choose File > Save As. Choose Save as type Text Only (*.txt). 
Click the Save button. 
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8. Launch Microsoft Excel. Choose Data > Import External Data > Import Data. Select the text file we just saved and 
click Open button. 

 

9. Choose Delimited and click Next button. 

 

10. Check the Other box and type a bar, "|", in the text box next to it. 
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11. Click Finish button and see the data has been imported into the spreadsheet. 

 

Changing tab orders 

The visual order (or so-called z-order) of fields in a Microsoft Word or Microsoft Publisher document determines their tab order in 
the final PDF file. There are two ways to manage tab orders.  

The first way: 

1. From the CenoPDF menu, choose Field Manager. 
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2. Click the Tab Order header in the list box to sort the fields. 

3. Select fields. You can hold Ctrl key or Shirt key to select multiple fields. 

4. Drag and drop the selected fields to the desired location. 

5. From the Edit menu, choose Set Tab Orderto commit the changes.  

 

 

The second way: 

1. Select the field in the Word document. 

2. Right click on the field and choose Order from the context menu. 

3. Choose from the sub-menu items to move the order up or down. 
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Grouping radio buttons 

Radio buttons are used when only one item can be selected among a group of items. Radio buttons that share the same name will 
be grouped together, among which only one can be checked at any given time. 

This tutorial demonstrates how to use radio buttons.  

1. Launch Microsoft Word. Type Red, Green and Blue on the document. Choose Add Radio Button from CenoPDF menu. 
Type color in the Name box. Type red in the Export Value box. Click the OK button. Drag the radio button next to 
appropriate position. 
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2. Follow the same step to create radio buttons for green and blue. Make sure they all use the same name color, but export 
different values. 



CenoPDF User's Manual Lystech Computing 

  http://www.lystech.com 

36 
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3. Choose Export to PDF from CenoPDF menu and open the PDF file in Adobe Reader. Note that only one radio button can 
be checked at a time. 
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Using hyperlink 

There are two ways to create hyperlinks. You can either simply type hyperlinks in your document. CenoPDF can recognize those 
links and convert them automatically. Or you can use the Link annotation. This walkthrough demonstrates both ways. The files used 
in this walkthrough can be downloaded here: Hyperlink.docand Hyperlink.pdf.  

1. Launch Microsoft Word. Type http://www.lystech.com and press Enter key. Type Click here to go to google. Choose Add 
Link from CenoPDF menu. Click the Add button. 

file:///C:\Luyang\OfficePdfAddinHelp\Content\create-hyperlink-in-pdf\Hyperlink.doc
file:///C:\Luyang\OfficePdfAddinHelp\Content\create-hyperlink-in-pdf\Hyperlink.pdf
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2. Choose Action Type as World Wide Web Link. Type http://www.google.com in the URL box. Click the OK button. 
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3. Drag the link field to cover the text. 
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4. Export to PDF file and open it in Adobe Reader to see the two links. 
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Inputting registration code 

After you receive the registration code, follow the steps below to register:  

1. Select the About CenoPDF from the CenoPDF menu. 

2. Copy and paste the registration code into the Registration Code edit box. 

3. Click the Enter button.  

An alternative way to input registration code is to put it into Addin.config file as follows: 

1.  Open the Notepad. The program can be run from desktop, Start menu > All Programs > Accessories > Notepad.  

2. In Notepad, open the Addin.config file under the CenoPDF installation folder. Usually it is under C:\Program 
Files\Lystech Computing\CenoPDF.  

3. Find the line <add key="RegCode" value=""/> and put the registration code into the double-quote after value. 

4. Save the file. 

After you register successfully, there will be no watermarks when you export to final PDF files.  

Enabling or disabling CenoPDF 

Once CenoPDF is successfully installed, by default, the following Microsoft Office applications will load CenoPDF automatically: 

 Microsoft Word 

 Microsoft Publisher 
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 Microsoft PowerPoint 

 Microsoft Excel 

Your Microsoft Office applications may take longer to start up with CenoPDF loaded. If you do not want to use CenoPDF in an 
application you may disable it using Add-in Manager. 

1. To enable or disable CenoPDF, you can go to Start menu, select All Programs > CenoPDF > Add-in Manager. 

 

2. Check or uncheck the application names and click the OK button to enable or disable CenoPDF. 

 

About PDF engine 

CenoPDF installs a component called novaPDF. You should not uninstall novaPDF from Windows Control Panel as CenoPDF uses 
this component when it generates PDF files. 

Note: Although CenoPDF utilizes novaPDF, the end user license you purchase for CenoPDF does not include novaPDF. This means 
you can use command CenoPDF > Export to PDF to create final PDF file, but if you want to print PDF via novaPDF printer you 
need to buy a separate license for it.  

If you use Microsoft Office 2007, you have opportunity to install the free Microsoft Export as PDF add-in. Those two PDF 
engines have different settings to control how PDF files are generated. You can change the settings in the Options dialog box.  

Note: Even if you installed the Microsoft Export as PDF add-in, you still need to use the command CenoPDF > Export to 
PDF to create fillable PDF files. 

Tip: If you do not like the PDF files generated by a PDF engine, you can switch to another one and see if it works better. 
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Microsoft Publisher settings 

Note for Publisher 2007 user You can skip the settings here if Microsoft Export as PDF add-in is installed and enabled in 
the Options dialog box. 

Note about novaPDF license Although CenoPDF uses novaPDF, CenoPDF end user license does not include novaPDF printer 
end user license. You should export to PDF files from CenoPDF. 

CenoPDF requires the following printer or page settings on documents if you use Microsoft Publisher. 

 The printer name must be novaPDF Pro 

 Printing options must be One page per sheet. 

 Paper size and orientation must be exactly same as the document. 

Here are the screen shots from different versions of Microsoft Publisher: 

 Microsoft Publisher 2007. Choose Print Setup from the File menu. 

 

 Microsoft Publisher 2002 or 2003. Choose Page Setup from the File menu. 
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Working with Microsoft Excel 

Sometimes Microsoft Excel may have paging problem that causes CenoPDF fields mis-align on the PDF pages. The following is an 
example of this situation. 

Excel file: 
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The PDF file generated from above Excel file. Notice the mis-alignment caused by wrong page break location. 

 

To workaround above problem, you should select the cell row that you want to put in next page and choose the command Insert 
> Page Break : 
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This is the screenshot after you added the page break: 

 

Export to PDF again. The problem should have been fixed. The following screenshot shows correct page break and field locations: 
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JavaScript for Acrobat 

To create PDF forms with more advanced features, such as display text box in a special format, or do some calculations based on 
input of fields, etc. you will need to use JavaScript for Acrobat. CenoPDF supports most of its features and you can use the 
following resources to learn it. 

 JavaScript's official name is ECMAScript. The standard is developed and maintained by the ECMA organisation. For the 
specification of this programming language and its syntax, please visit Standard ECMA-262 ECMAScript Language 
Specification. You can also google it. There are a lot of tutorials online. 

 JavaScript for Acrobat is Adobe's implementation of ECMA standard. For all functions it supports, please visit JavaScript for 
Acrobat API Reference. All available resources are also on Adobe's web site:  
http://www.adobe.com/devnet/acrobat/javascript.html. 

 The information about formatting text boxes can be found at Acrobat Forms API Reference. The scripts we are particularly 
interested in are AFDate_KeystrokeEx, AFDate_FormatEx, AFTime_Keystroke, AFTime_Format, 
AFPercent_Keystroke, AFPercent_Format, AFSpecial_Keystroke, AFSpecial_Format, AFNumber_Format, 
AFNumber_Keystroke. You can search for those names in the reference to get detailed information. See also: Format 
text box 

 We highly recommend you turn on JavaScript error message in Adobe Reader in order to help you troubleshoot your 
scripts. Choose Edit > Preferences command in Adobe Reader. Choose JavaScript categories. Check the box Enable 
Acrobat JavaScript and Show console on errors and messages so that a console window will show you the error in 
your script if there is any. 

http://www.ecma-international.org/publications/standards/Ecma-262.htm
http://www.ecma-international.org/publications/standards/Ecma-262.htm
http://www.adobe.com/devnet/acrobat/pdfs/js_api_reference.pdf
http://www.adobe.com/devnet/acrobat/pdfs/js_api_reference.pdf
http://www.adobe.com/devnet/acrobat/javascript.html
http://www.adobe.com/devnet/acrobat/pdfs/FormsAPIReference.pdf
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Using document level JavaScript 

If you want your JavaScript functions to be shared in your document, you can create document level JavaScript as follows. 

1. Choose command CenoPDF > Document Settings > Document Level JavaScript 

2. Click the Add button and type in a script name. 

3. Type your script functions in the JavaScript box. 

4. Click the OK button 

Functions created in this way could be called from any event triggers. 

Format text box using JavaScript 

The basic format settings are usually enough for most cases. If you want to have more advanced control of format, you can use 
JavaScript. 

Note: Using keystroke and format JavaScript will override format settings. 

The information about JavaScript functions that are used to format form fields can be found at Acrobat Forms API Reference. The 
functions we are particularly interested in are AFDate_KeystrokeEx, AFDate_FormatEx, AFTime_Keystroke, 
AFTime_Format, AFPercent_Keystroke, AFPercent_Format, AFSpecial_Keystroke, AFSpecial_Format, 
AFNumber_Format, AFNumber_Keystroke. You can search for those names in the reference to get detailed information.  

The above functions with Format suffix should be put in the Format trigger. When a PDF viewer displays the contents of a text box, 
it calls Format trigger before showing it. The functions with Keystroke suffix, should be put in the Keystroke trigger. Any time user 
types in the text box, the Keystroke trigger will be called to validate the input. 

Here is the list of frequently used formats:  

Description Example Javascript 

Date 01/31/2008 AFDate_FormatEx("mm/dd/yyyy"); 
AFDate_KeystrokeEx("mm/dd/yyyy"); 

Date 1/31/2008 AFDate_FormatEx("m/d/yyyy"); 
AFDate_KeystrokeEx("m/d/yyyy"); 

http://www.adobe.com/devnet/acrobat/pdfs/FormsAPIReference.pdf
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Description Example Javascript 

Date 1/31/08 AFDate_FormatEx("m/d/yy"); 
AFDate_KeystrokeEx("m/d/yy"); 

Zip code 12345 AFSpecial_Keystroke(0); 
AFSpecial_Format(0);  

Zip+4 12345-1234 AFSpecial_Keystroke(1); 
AFSpecial_Format(1);  

Phone number (123) 456-7890 AFSpecial_Keystroke(2); 
AFSpecial_Format(2);  

Social Security Number 123-45-6789 AFSpecial_Keystroke(3); 
AFSpecial_Format(3);  

Money (minus sign if negative) $12,345.00 
-$12,345.00  

AFNumber_Keystroke(2, 0, 0, 0, "$", true); 
AFNumber_Format(2, 0, 0, 0, "$", true);  

Money (parentheses if negative) $12,345.00 
($12,345.00)  

AFNumber_Keystroke(2, 0, 2, 0, "$", true); 
AFNumber_Format(2, 0, 2, 0, "$", true);  

This tutorial demonstrates how to create a text box and display its contents in phone number format using AFSpecial_Format. 
Demo files can be downloaded here: PhoneNumber.doc and PhoneNumber.pdf. 

1. Launch Microsoft Word. Choose Add Text Box from CenoPDFmenu. In the Text Box Properties dialog box, click 
Format and Validate tab. Click the Format trigger. Type 

AFSpecial_Format(2); 

in the JavaScript window. Click the OK button.  

file:///C:\Luyang\OfficePdfAddinHelp\Content\format-pdf-text-box\PhoneNumber.doc
file:///C:\Luyang\OfficePdfAddinHelp\Content\format-pdf-text-box\PhoneNumber.pdf
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2. Export to PDF file and open it in Adobe Reader. Type a phone number in the text box and press Enter. Note the phone 
number is displayed in correct format. 
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Restricting characters in a text box 

If you do not want your end users to input certain characters into a text box, you can use JavaScript to do that. This walkthrough 
demonstrate how to make a text box not accept characters: #@+!\[]. 

The files used in this walkthrough can be downloaded here: DiscardChar.doc and DiscardChar.pdf. 

1. Launch Microsoft Word. Choose CenoPDF > Add Text Box to add a text box. In the Text Box Properties dialog box, 
choose Advanced tab. 

2. Click the Keystroke trigger. Copy and paste the script below into the Execute the JavaScript box. 

for(;;) 

{ 

    var v = event.change.replace(/[#@+!\\\[\]]/, ""); 

    if(v == event.change) 

        break; 

    event.change = v; 

} 

Note: the first parameter in the above replace() function is a regular expression enclosed by two slashes. The script will 
replace the text that matches the regular expression in a keystroke input (this may include copy and paste action) with an 
empty string, and keep looping until nothing is replaced. 

3. Click the OK button and choose command CenoPDF > Export to PDF. 

file:///C:\Luyang\OfficePdfAddinHelp\Content\restrict-character-from-text-box\DiscardChar.doc
file:///C:\Luyang\OfficePdfAddinHelp\Content\restrict-character-from-text-box\DiscardChar.pdf
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Using check box 

This walkthrough demonstrate how to detect and control the state of check boxes. We will create three check boxes and implement 
the logic that if the first box is checked the other two will be checked as well. 

The files used in this walkthrough can be downloaded here: checkbox.docand checkbox.pdf. 

1. Launch Microsoft Word. Choose CenoPDF > Add Check Box to add three check boxes and name them as selectall, box1 
and box2. 

2. Go to the properties dialog box of the selectallcheck box and choose Actions tab > Mouse Up trigger > Add button > 
JavaScriptAction Type.  

3. Copy and paste the following script in the JavaScript box: 

if(this.getField("selectall").isBoxChecked(0)) 

{ 

    this.getField("box1").checkThisBox(0, true); 

    this.getField("box2").checkThisBox(0, true); 

}  

4. Choose command CenoPDF > Export to PDF. 

Using combo box and list box 

This walkthrough demonstrates how to use combo box and list box to create a simple order form. It also shows how to use 
document level JavaScript. 

The files used in this walkthrough can be downloaded here: OrderForm.docand OrderForm.pdf. 

1. Launch Microsoft Word. Type necessary texts. Choose CenoPDF > Add Combo Box. Click the Options tab. Type 
Motherboard in the Item box and 80.00 in the Export Value box. Click the Add button. This defines the price of the 
motherboard is $80. 

file:///C:\Luyang\OfficePdfAddinHelp\Content\use-pdf-check-box\checkbox.doc
file:///C:\Luyang\OfficePdfAddinHelp\Content\use-pdf-check-box\checkbox.pdf
file:///C:\Luyang\OfficePdfAddinHelp\Content\use-pdf-combo-box\OrderForm.doc
file:///C:\Luyang\OfficePdfAddinHelp\Content\use-pdf-combo-box\OrderForm.pdf
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2. Add more items into above box: 

Pentium 4 => 100.00; AMD CPU => 90.00; CD-ROM => 20.00; Keyboard => 10.00; Mouse => 12.00 
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3. Follow the same way as above, choose CenoPDF> Add List Box to add a list box named shipping and add a few items to 
it. 
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4. Add a text box named total and make it read-only. 
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5. Choose CenoPDF > Document Settings > Document Level JavaScript tab. Click the Add button. 

function calculateTotal() 

{  

    getField("total").value = getField("computerparts").value + 

getField("shipping").value; 

} 
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6. Go to the properties box of the combo box and list box. Click the Actions tab. Click the OnBlur trigger and the Add 
button to add a JavaScript action with the following script: 

calculateTotal(); 

7. The final document looks like this: 
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8. Choose CenoPDF > Export to PDF to generate the final PDF file and open it in Adobe Reader. 
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Submitting form data via email using JavaScript 

This walkthrough demonstrates how to submit the information in a PDF form via email using JavaScript. The files used in this 
walkthrough can be downloaded here: SubmitByEmail.doc and SubmitByEmail.pdf. They have been tested with Adobe Reader 8 and 
Microsoft Outlook 2003.  

An alternative way of emailing form data is to use Email Form Data action. 

1. Launch Microsoft Word. Add five text boxes by choosing Add Text Box on CenoPDF menu. Set the name of those text 
boxes to DestinationEmail, FirstName, LastName,Street and Comments as the following screen shot. 

file:///C:\Luyang\OfficePdfAddinHelp\Content\submit-pdf-form-via-email\SubmitByEmail.doc
file:///C:\Luyang\OfficePdfAddinHelp\Content\submit-pdf-form-via-email\SubmitByEmail.pdf
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2. Choose Add Push Button on CenoPDF menu. In the Push Button Properties dialog box, click Options tab. Set the 
normal button text as Send Email. 
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3. Click the Actions tab, the Mouse Up trigger and the Add button. 
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4. Choose Action Type as JavaScript. Input the following JavaScript, then click the OK button. 

var destEmailField = this.getField("DestinationEmail"); 

 

var firstNameField = this.getField("FirstName"); 

var lastNameField = this.getField("LastName"); 

var streetField = this.getField("Street"); 

var commentsField = this.getField("Comments"); 

 

var emailBody =  

"First Name: " + firstNameField.valueAsString + "\n" + 

"Last Name: " + lastNameField.valueAsString + "\n" + 

"Street: " + streetField.valueAsString + "\n" + 

"Comments: " + commentsField.valueAsString; 

 

app.mailMsg(true, destEmailField.value, "", "", "Test Message", emailBody);  
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5. Here is the button we just added. 
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6. Export the document to a PDF file. Open it in Adobe Reader. Fill all fields. Click the Send Email button. 
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7. The email client, Microsoft Outlook in our example, pops up with the contents we just created from the PDF file. 
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Note: This step uses Messaging Application Programming Interface (MAPI) in your computer to open Microsoft Outlook. 
MAPI is a messaging architecture that allows clients (Adobe Reader) to interact with email program. In most cases, MAPI is 
set up automatically after an email program, such as Microsoft Outlook, is installed. In very rare cases, however, if your 
user's computer does not have MAPI or it is not configured correctly, it is always a good idea for you to provide alternative 
ways, such as fax, to send information back.  

Test MAPI: Go to Windows Explorer, right click on any file and choose Send To > Mail Recipient from the context 
menu. If your email client opens, your MAPI is OK. Otherwise, if your email client does not open, your MAPI is probably 
not set up correctly and this step may not work either. 

Submitting form data to a web site 

This walkthrough demonstrates how to submit the information in a PDF form to a web site via a web browser. You will need some 
server side programming skills to construct a web page to accept the data. In this walkthrough, the data will be submitted to our 
web site and we will display them on the web page.  

The files used in this walkthrough can be downloaded here: SubmitToWeb.doc and SubmitToWeb.pdf.  

1. Launch Microsoft Word. Choose CenoPDF > Add Text Box to add a text box and name it as testfield. This name will be 
submitted along with the text to identify the field. 

file:///C:\Luyang\OfficePdfAddinHelp\Content\submit-pdf-form-to-web-site\SubmitToWeb.doc
file:///C:\Luyang\OfficePdfAddinHelp\Content\submit-pdf-form-to-web-site\SubmitToWeb.pdf
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2. Choose CenoPDF > Add Push Button to add a button and name it as submitbutton. Set the button text as Submit. 
Choose Actions tab > Mouse Up trigger > Add button. 
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3. Choose Action Type as Submit Form. Type http://www.lystech.com/Tutorial/SubmitToWeb/ProcessForm.aspxin the URL 
box. Set the export format as HTML. Click the OK button. 
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4. You are free to use any programming language to develop your web application. In this demo, the web page 
ProcessForm.aspx was written in Microsoft C#.The code to get and display the submitted fields is as follows. 

...  

You have typed <span style="color: Red"> "<% Response.Write(Request.Form["testfield"]);%>" 

</span> in the text box.  

...  

5. Export to PDF. Put the PDF file on your web site and create a link to it. Here is the link on our web site to the 
SubmitToWeb.pdf.You must have Adobe Reader installed on your computer. Click the above link to open the PDF file in 
Internet Explorer. Type something in the text box and click the Submit button. The data will be submitted to our web site. 

file:///C:\Luyang\OfficePdfAddinHelp\Content\submit-pdf-form-to-web-site\SubmitToWeb.pdf
file:///C:\Luyang\OfficePdfAddinHelp\Content\submit-pdf-form-to-web-site\SubmitToWeb.pdf
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Creating a PDF calculator 

This walkthrough demonstrates how to calculate sum of two numbers and days between two dates. The files used in this 
walkthrough can be downloaded here: Calculator.doc and Calculator.pdf. 

1. Launch Microsoft Word. Add text boxes num1, num2, result, date1, date2 and days. Add push button calculate and 
calculate2. Make the document look like the screenshot below: 

file:///C:\Luyang\OfficePdfAddinHelp\Content\calculate-in-pdf\Calculator.doc
file:///C:\Luyang\OfficePdfAddinHelp\Content\calculate-in-pdf\Calculator.pdf
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2. Add the following JavaScript to the Mouse Up trigger of the calculatebutton. 

var v1 = this.getField("num1").value; 

var v2 = this.getField("num2").value; 

 

this.getField("result").value = v1 + v2;  
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3. Add the following JavaScript to the Mouse Up trigger of the calculate2 button. 

var v1 = this.getField("date1").value; 

var v2 = this.getField("date2").value; 

 

var d1 = new Date(v1); 

var d2 = new Date(v2); 

 

var days = Math.abs(d1.getTime() - d2.getTime()) / 1000 / 60 / 60 / 24; 

 

this.getField("days").value = days;  

4. Add the following JavaScript to the Keystroke trigger of both date1 and date2 fields. 

AFDate_KeystrokeEx("mm/dd/yyyy");  

5. Add the following JavaScript to the Format trigger of both date1 and date2 fields. 

AFDate_FormatEx("mm/dd/yyyy");  

6. Choose Export to PDF from CenoPDF menu to create the PDF file and open it in Adobe Reader. 



CenoPDF User's Manual Lystech Computing 

  http://www.lystech.com 

76 

 

Sample order form 

This sample shows you how to do a calculation without clicking a push button, instead, the calculation is triggered by the On Blur 
trigger that occurs when a text box loses input focus. The files can be downloaded here: orderform.doc and orderform.pdf. 

Here is the screenshot of the finished form: 

file:///C:\Luyang\OfficePdfAddinHelp\Content\create-pdf-order-form\orderform.doc
file:///C:\Luyang\OfficePdfAddinHelp\Content\create-pdf-order-form\orderform.pdf
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The highlights of the orderform.doc file are as follows. 

 From CenoPDF menu, choose Document Settings > Document Level JavaScript. You can see there are a few shared 
functions. Those are used to calculate the TOTAL FEE. 

 On Blur trigger of all item boxes are handled respectively in order to start a calculation. 

 All TOTAL boxes are read-only. 

  

  

Exporting to PDF from a database 

CenoPDF can create a template and use a database to populate fields in the template to batch create PDF forms. Any database 
product such as SQL Server, Access, Excel etc, as long as it can provide a connection string, it can be used in CenoPDF. For more 
information please see Export to PDF from Database dialog box. 

This walkthrough demonstrates the steps to batch create PDF forms using the data in an Excel spreadsheet. Each row of the 
spreadsheet creates one PDF file. The text boxes and radio buttons on the PDF file are filled with the data from that row. The files 
used in this walkthrough can be downloaded here: Template.docand Book1.xls. 

1. Use Microsoft Word to create the template file Template.doc. There are three text boxes and two radio buttons in the file. 
Their names are firstname, lastname,street andjob. Note that two radio buttons share the same name but they export 
different values, job1 and job2. 

file:///C:\Luyang\OfficePdfAddinHelp\Content\create-pdf-from-excel-database\Template.doc
file:///C:\Luyang\OfficePdfAddinHelp\Content\create-pdf-from-excel-database\Book1.xls
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2. Use Microsoft Excel to create a spreadsheet, Book1.xls, which will serve as a database. The first row is column names. If 
you want to use the data in a PDF field, its column name must be in the format of fieldname_propertyname for a regular 
field or fieldname_propertyname_index  for radio buttons. 

For a text box, the Text property is most frequently used. In our example, the column names are firstname_Text, 
lastname_Textand street_Text corresponding to the template file. 

For radio buttons, because many radio buttons can share the same name, you have to append an index to the field name to 
distinguish them. The index is same as the tab order in the same group of radio buttons. In our example, we want to set 
which button is checked. So the column names are job_DefaultIsChecked_0 for the job1 button and 
job_DefaultIsChecked_0 for the job2 button. 

file:///C:\Luyang\OfficePdfAddinHelp\Content\create-pdf-from-excel-database\Book1.xls
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3. If you want see other property names besides the ones used in this example, you can choose CenoPDF > Options > 
General and check Always use property grid to edit field properties box. Edit properties of a PDF field, you will see 
all property names at left side of the grid. 

 



CenoPDF User's Manual Lystech Computing 

  http://www.lystech.com 

80 

4. In Microsoft Word, choose command CenoPDF> Export to PDF from Database. Copy and paste the following text into 
the Connection String box: 

Provider=Microsoft .Jet.OLEDB.4.0;Data Source=C:\myfolder\Book1.xls;Extended Properties="Excel 

8.0;HDR=YES;"  

If your file is in Excel 2007 format (.xlsx), use this connection string: 

Provider=Microsoft .ACE.OLEDB.12.0;Data Source=C: \myfolder\Book1.xlsx;Extended Properties="Excel  
12.0;HDR=YES;"  

(Insta l l  2007 Off ice System Driver: Data Connect iv ity Components  i f  it g ives you any error.)  

Note You must change the path of Data Source to the real path in your computer. 

5. For Excel spreadsheet, a table name is the sheet name plus a dollar sign. So type Sheet1$ into the Table Name box. If 
you use Microsoft SQL server, the dollar sign is not needed.  

6. Click the Test button. You should see your data in the Database Contents grid. 

 

7. Type C:\PDFOutput\[firstname_Text][count].pdfinto Output PDF File Path Pattern box and click the OK button. Ten 
PDF files are generated at the path you specified. 

http://www.microsoft.com/downloads/details.aspx?FamilyID=7554F536-8C28-4598-9B72-EF94E038C891&displaylang=en
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See also 
Export to PDF from Database dialog box. 

Text Box Properties dialog box 

This dialog box allows users to set or change the properties of the selected PDF text box in the active document. You can  bring up 
this dialog box by choosing Field Properties from the CenoPDF menu while a PDF text box is selected. 

Button/Section Description 

Name Name of the text box. The name cannot be empty. 

Short Description A brief description of the text box. 

Appearance tab 

Button/Section Description 

Border Color If this box is checked, the border color of the PDF field is enabled and you can pick 
a color by clicking the button next to it; Otherwise, the border of the field is not 
drawn. 

Background Color If this box is checked, the background color of the PDF field is enabled and you can 
pick a color by clicking the button next to it; Otherwise, the background of the field 
is not drawn. 

Width Choose the border width of the PDF field. 

Style Choose the border style of the PDF field. 

Text Color Choose text color for the PDF field by clicking the button. 

Font Choose the font for the PDF field. Note that the first 14 fonts are PDF built-in fonts. 
All the other ones are the fonts installed on your Windows system. 

Size Choose or type in the font size for the PDF field. If the Auto is selected, the font size 
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Button/Section Description 

will be adjusted automatically to fit the field. 

Read Only Check the box if user is not allowed to edit the contents of the PDF field. 

Required Check the box to indicate this PDF field is required and has to be filled in when user 
submits the form. The PDF viewer will prompt the user to fill in the field before  the 
form can be successfully submitted. 

Form Field Is Specify the visibility of the PDF field. 

Orientation Specify the orientation of the PDF field. 

Options tab 

Button/Section Description 

Default The default text in the text box. 

Alignment Alignment of the text in the text box. 

Multi-line If this box is checked, the text box can accept multiple lines as input; Otherwise, 
there can be only one single line in the text box. 

Do Not Scroll If this box is checked, the contents in the text box will not be scrollable. In this 
case, when the contents reaches the boundary of the text box,  if the font size is set 
as Auto, the font will shrink accordingly; otherwise no more texts can be entered. 

Limit of Characters The maximum number of characters can be entered into the text box. 

Password If this box is checked, the contents in the text box will be password protected and 
displayed as stars. This option is only available if the Do Not Spell Check is 
checked. 

Do Not Spell Check If this box is checked, the spelling of the contents in the text box will be checked by 
the PDF viewer. 

Format tab 

This tab sets the display format of a field.  

Button/Section Description 

Format the field as 
Choose the format of the field. 

Date time style 
Choose date time style. 

Number of digits after 
decimal point 

Number of digits after decimal point. 

Use comma separator Choose whether use comma as separator for a number. 

Negative number style Choose how to display a negative number. 

Currency symbol Set a currency symbol that can be displayed before or after the number. 
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Actions tab 

Button/Section Description 

Trigger 
List of events to trigger the actions defined in the Action list on its right: 

Mouse Up Release left mouse button on the PDF 
field 

Mouse Down Press left mouse button on the PDF field 

Mouse Enter Mouse cursor enters the PDF field 

Mouse Exit Mouse cursor exits the PDF field 

On Focus The PDF field receives input focus 

On Blur Input focus is lost from the PDF field 
 

Action You can define a list of actions for any trigger event listed in the Trigger box. When 
a trigger event occurs, the associated actions defined in this box will be executed 
sequentially. You can use Add, Edit, Delete, Up, Down button to modify the 
action list. 

Add Add an action for the selected trigger. The Action Properties dialog box will pop up. 

Edit Edit the selected action. The Action Properties dialog box will pop up. 

Delete Delete the selected action. 

Up Move the selected action up in the list. 

Down Move the selected action down in the list. 

See also 
Action Properties dialog box 

Advanced tab 

This tab sets the JavaScript to format and validate the PDF field when certain events occur. See Adobe Acrobat online help for more 
information about JavaScript programming.  

Button/Section Description 

Trigger 
List of events to trigger the JavaScript: 

Keystroke When a key is pressed 

Format When the PDF viewer formats the field 

Validate When the PDF viewer validates the contents of the 
field 

Calculate When the PDF viewer calculates the contents of the 
field 

 

Execute the JavaScript 
Add JavaScript scripts that are to be executed when the selected trigger event occurs. 

Note: If you input keystroke or format script here, the format settings (set in another tab) of the 
field will be ignored. 

Check Box Properties dialog box 

This dialog box allows user to set or change properties of the selected PDF check box in the active document. You can bring up this 
dialog box by choosing Field Properties from the CenoPDF menu while a PDF check box is selected. 
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Button/Section Description 

Name Name of the check box. The name cannot be empty. 

Short Description A brief description of the check box. 

Appearance tab 

Button/Section Description 

Border Color If this box is checked, the border color of the PDF field is enabled and you can pick 
a color by clicking the button next to it; Otherwise, the border of the field is not 
drawn. 

Background Color If this box is checked, the background color of the PDF field is enabled and you can 
pick a color by clicking the button next to it; Otherwise, the background of the field 
is not drawn. 

Width Choose the border width of the PDF field. 

Style Choose the border style of the PDF field. 

Text Color Choose text color for the PDF field by clicking the button. 

Font Choose the font for the PDF field. Note that the first 14 fonts are PDF built-in fonts. 
All the other ones are the fonts installed on your Windows system. 

Size Choose or type in the font size for the PDF field. If the Auto is selected, the font size 
will be adjusted automatically to fit the field. 

Read Only Check the box if user is not allowed to edit the contents of the PDF field. 

Required Check the box to indicate this PDF field is required and has to be filled in when user 
submits the form. The PDF viewer will prompt the user to fill in the field before  the 
form can be successfully submitted. 

Form Field Is Specify the visibility of the PDF field. 

Orientation Specify the orientation of the PDF field. 

Options tab 

Button/Section Description 

Check Style The shape of the check box. 

Export Value The value of the check box. When the form is submitted, this value will be 
submitted to the server if the check box is checked. 

Default Is Checked If this box is checked, the PDF check box will be checked by default when a viewer 
program displays it. 

Actions tab 

Button/Section Description 

Trigger 
List of events to trigger the actions defined in the Action list on its right: 

Mouse Up Release left mouse button on the PDF 
field 

Mouse Down Press left mouse button on the PDF field 
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Button/Section Description 

Mouse Enter Mouse cursor enters the PDF field 

Mouse Exit Mouse cursor exits the PDF field 

On Focus The PDF field receives input focus 

On Blur Input focus is lost from the PDF field 
 

Action You can define a list of actions for any trigger event listed in the Trigger box. When 
a trigger event occurs, the associated actions defined in this box will be executed 
sequentially. You can use Add, Edit, Delete, Up, Down button to modify the 
action list. 

Add Add an action for the selected trigger. The Action Properties dialog box will pop up. 

Edit Edit the selected action. The Action Properties dialog box will pop up. 

Delete Delete the selected action. 

Up Move the selected action up in the list. 

Down Move the selected action down in the list. 

See also 
Action Properties dialog box 

Radio Button Properties dialog box 

This dialog box allows you to set or change properties of the selected PDF radio button in the active document. You can bring up 
this dialog box by choosing Field Properties from the CenoPDF menu while a PDF radio button is selected. 

Button/Section Description 

Name Name of the radio button. The name cannot be empty. If more than one radio 
button share the same name, they will be grouped together automatically, among 
which there can be only one button checked at any given time. 

Short Description A brief description of the radio button. 

Appearance tab 

Button/Section Description 

Border Color If this box is checked, the border color of the PDF field is enabled and you can pick 
a color by clicking the button next to it; Otherwise, the border of the field is not 
drawn. 

Background Color If this box is checked, the background color of the PDF field is enabled and you can 
pick a color by clicking the button next to it; Otherwise, the background of the field 
is not drawn. 

Width Choose the border width of the PDF field. 

Style Choose the border style of the PDF field. 

Text Color Choose text color for the PDF field by clicking the button. 

Font Choose the font for the PDF field. Note that the first 14 fonts are PDF built-in fonts. 
All the other ones are the fonts installed on your Windows system. 

Size Choose or type in the font size for the PDF field. If the Auto is selected, the font size 
will be adjusted automatically to fit the field. 

Read Only Check the box if user is not allowed to edit the contents of the PDF field. 
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Button/Section Description 

Required Check the box to indicate this PDF field is required and has to be filled in when user 
submits the form. The PDF viewer will prompt the user to fill in the field before  the 
form can be successfully submitted. 

Form Field Is Specify the visibility of the PDF field. 

Orientation Specify the orientation of the PDF field. 

Options tab 

Button/Section Description 

Check Style The shape of the radio button. 

Export Value The value of the radio button. If the form is submitted, this value will be submitted 
to the server if this radio button is checked. 

Default Is Checked If this box is checked, this PDF radio button will be checked by default when a 
viewer program opens it. 

Actions tab 

Button/Section Description 

Trigger 
List of events to trigger the actions defined in the Action list on its right: 

Mouse Up Release left mouse button on the PDF 
field 

Mouse Down Press left mouse button on the PDF field 

Mouse Enter Mouse cursor enters the PDF field 

Mouse Exit Mouse cursor exits the PDF field 

On Focus The PDF field receives input focus 

On Blur Input focus is lost from the PDF field 
 

Action You can define a list of actions for any trigger event listed in the Trigger box. When 
a trigger event occurs, the associated actions defined in this box will be executed 
sequentially. You can use Add, Edit, Delete, Up, Down button to modify the 
action list. 

Add Add an action for the selected trigger. The Action Properties dialog box will pop up. 

Edit Edit the selected action. The Action Properties dialog box will pop up. 

Delete Delete the selected action. 

Up Move the selected action up in the list. 

Down Move the selected action down in the list. 

See also 
Action Properties dialog box 

List Box Properties dialog box 

This dialog box allows user to set or change properties of the selected PDF list box on the active document. You can bring up this 
dialog box by choosing Field Properties from the CenoPDF menu while a PDF list box is selected. 

Button/Section Description 
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Button/Section Description 

Name Name of the list box. The name cannot be empty. 

Short Description A brief description of the list box. 

Appearance tab 

Button/Section Description 

Border Color If this box is checked, the border color of the PDF field is enabled and you can pick 
a color by clicking the button next to it; Otherwise, the border of the field is not 
drawn. 

Background Color If this box is checked, the background color of the PDF field is enabled and you can 
pick a color by clicking the button next to it; Otherwise, the background of the field 
is not drawn. 

Width Choose the border width of the PDF field. 

Style Choose the border style of the PDF field. 

Text Color Choose text color for the PDF field by clicking the button. 

Font Choose the font for the PDF field. Note that the first 14 fonts are PDF built-in fonts. 
All the other ones are the fonts installed on your Windows system. 

Size Choose or type in the font size for the PDF field. If the Auto is selected, the font size 
will be adjusted automatically to fit the field. 

Read Only Check the box if user is not allowed to edit the contents of the PDF field. 

Required Check the box to indicate this PDF field is required and has to be filled in when user 
submits the form. The PDF viewer will prompt the user to fill in the field before  the 
form can be successfully submitted. 

Form Field Is Specify the visibility of the PDF field. 

Orientation Specify the orientation of the PDF field. 

Options tab 

Button/Section Description 

Item The text of the item. 

Export Value The value associated with the item. When the form is submitted, the value of the 
selected item will be submitted. 

All Items All items in the list box. You can choose any item and use the button Delete, 
Default, Up and Down to operate on it. 

Add Add an item to the list box. 

Update Update the selected item in the list box. 

Delete Delete the selected item from the list box. 

Default Make the selected item as the default item in the list box. Default item will be 
initially selected when a PDF viewer displays the list box. 

Up Move the selected item up in the list box. 

Down Move the selected item down in the list box. 
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Button/Section Description 

Text This button popups a dialog box that allows you to input items in text format. Each 
line of text becomes a list box item. 

Sort Items If this box is checked, all items in the list box will be sort alphabetically. 

Multiple Selection If this box is checked, the PDF viewer will allow users to select multiple items in the 
list box. 

Actions tab 

Button/Section Description 

Trigger 
List of events to trigger the actions defined in the Action list on its right: 

Mouse Up Release left mouse button on the PDF 
field 

Mouse Down Press left mouse button on the PDF field 

Mouse Enter Mouse cursor enters the PDF field 

Mouse Exit Mouse cursor exits the PDF field 

On Focus The PDF field receives input focus 

On Blur Input focus is lost from the PDF field 
 

Action You can define a list of actions for any trigger event listed in the Trigger box. When 
a trigger event occurs, the associated actions defined in this box will be executed 
sequentially. You can use Add, Edit, Delete, Up, Down button to modify the 
action list. 

Add Add an action for the selected trigger. The Action Properties dialog box will pop up. 

Edit Edit the selected action. The Action Properties dialog box will pop up. 

Delete Delete the selected action. 

Up Move the selected action up in the list. 

Down Move the selected action down in the list. 

See also 
Action Properties dialog box 

Advanced tab 

This tab sets the JavaScript to format and validate the PDF field when certain events occur. See Adobe Acrobat online help for more 
information about JavaScript programming.  

Button/Section Description 

Trigger 
List of events to trigger the JavaScript: 

Keystroke When a key is pressed 

Format When the PDF viewer formats the field 

Validate When the PDF viewer validates the contents of the 
field 

Calculate When the PDF viewer calculates the contents of the 
field 
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Button/Section Description 

Execute the JavaScript 
Add JavaScript scripts that are to be executed when the selected trigger event occurs. 

Note: If you input keystroke or format script here, the format settings (set in another tab) of the 
field will be ignored. 

Combo Box Properties dialog box 

This dialog box allows user to set or change properties of the selected PDF combo box in the active document. You can bring up 
this dialog box by choosing Field Properties from the CenoPDF menu while a PDF combo box is selected. 

Button/Section Description 

Name Name of the combo box. The name cannot be empty. 

Short Description A brief description of the combo box. 

Appearance tab 

Button/Section Description 

Border Color If this box is checked, the border color of the PDF field is enabled and you can pick 
a color by clicking the button next to it; Otherwise, the border of the field is not 
drawn. 

Background Color If this box is checked, the background color of the PDF field is enabled and you can 
pick a color by clicking the button next to it; Otherwise, the background of the field 
is not drawn. 

Width Choose the border width of the PDF field. 

Style Choose the border style of the PDF field. 

Text Color Choose text color for the PDF field by clicking the button. 

Font Choose the font for the PDF field. Note that the first 14 fonts are PDF built-in fonts. 
All the other ones are the fonts installed on your Windows system. 

Size Choose or type in the font size for the PDF field. If the Auto is selected, the font size 
will be adjusted automatically to fit the field. 

Read Only Check the box if user is not allowed to edit the contents of the PDF field. 

Required Check the box to indicate this PDF field is required and has to be filled in when user 
submits the form. The PDF viewer will prompt the user to fill in the field before  the 
form can be successfully submitted. 

Form Field Is Specify the visibility of the PDF field. 

Orientation Specify the orientation of the PDF field. 

Options tab 

Button/Section Description 

Item The text of the item. 

Export Value The value associated with the item. When the form is submitted, the value of the 
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Button/Section Description 

selected item will be submitted. 

All Items All items in the combo box. You can choose an item from the list and use the button 
Delete, Default, Up and Down to operate on it. 

Add Add an item to the combo box. 

Update Update the selected item in the combo box. 

Delete Delete the selected item from the combo box. 

Default Make the selected item as the default item in the combo box. Default item will be 
initially selected when the PDF viewer displays the list box. 

Up Move the selected item up in the combo box. 

Down Move the selected item down in the combo box. 

Text This button popups a dialog box that allows you to input items in text format. Each 
line of text becomes a combo box item. 

Sort Items If this box is checked, all items in the combo box will be sorted alphabetically. 

Editable If this box is checked, combo box is displayed as a combination of an text box and a 
list box; otherwise, it is displayed as a drop down list box. 

Do Not Spell Check This option is only available if the combo box is editable. If this box is checked, the 
spelling of the contents in the text box will be checked by the PDF viewer. 

Format tab 

This tab sets the display format of a field.  

Button/Section Description 

Format the field as 
Choose the format of the field. 

Date time style 
Choose date time style. 

Number of digits after 
decimal point 

Number of digits after decimal point. 

Use comma separator Choose whether use comma as separator for a number. 

Negative number style Choose how to display a negative number. 

Currency symbol Set a currency symbol that can be displayed before or after the number. 

Actions tab 

Button/Section Description 

Trigger 
List of events to trigger the actions defined in the Action list on its right: 

Mouse Up Release left mouse button on the PDF 
field 

Mouse Down Press left mouse button on the PDF field 
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Button/Section Description 

Mouse Enter Mouse cursor enters the PDF field 

Mouse Exit Mouse cursor exits the PDF field 

On Focus The PDF field receives input focus 

On Blur Input focus is lost from the PDF field 
 

Action You can define a list of actions for any trigger event listed in the Trigger box. When 
a trigger event occurs, the associated actions defined in this box will be executed 
sequentially. You can use Add, Edit, Delete, Up, Down button to modify the 
action list. 

Add Add an action for the selected trigger. The Action Properties dialog box will pop up. 

Edit Edit the selected action. The Action Properties dialog box will pop up. 

Delete Delete the selected action. 

Up Move the selected action up in the list. 

Down Move the selected action down in the list. 

See also 
Action Properties dialog box 

Advanced tab 

This tab sets the JavaScript to format and validate the PDF field when certain events occur. See Adobe Acrobat online help for more 
information about JavaScript programming.  

Button/Section Description 

Trigger 
List of events to trigger the JavaScript: 

Keystroke When a key is pressed 

Format When the PDF viewer formats the field 

Validate When the PDF viewer validates the contents of the 
field 

Calculate When the PDF viewer calculates the contents of the 
field 

 

Execute the JavaScript 
Add JavaScript scripts that are to be executed when the selected trigger event occurs. 

Note: If you input keystroke or format script here, the format settings (set in another tab) of the 
field will be ignored. 

Push Button Properties dialog box 

This dialog box allows user to set or change properties of the selected PDF push button on the active document. You can bring up 
this dialog box by choosing Field Properties from the CenoPDF menu while a PDF push button is selected. 

Button/Section Description 

Name Name of the push button. The name cannot be empty. 

Short Description A brief description of the push button. 
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Appearance tab 

Button/Section Description 

Border Color If this box is checked, the border color of the PDF field is enabled and you can pick 
a color by clicking the button next to it; Otherwise, the border of the field is not 
drawn. 

Background Color If this box is checked, the background color of the PDF field is enabled and you can 
pick a color by clicking the button next to it; Otherwise, the background of the field 
is not drawn. 

Width Choose the border width of the PDF field. 

Style Choose the border style of the PDF field. 

Text Color Choose text color for the PDF field by clicking the button. 

Font Choose the font for the PDF field. Note that the first 14 fonts are PDF built-in fonts. 
All the other ones are the fonts installed on your Windows system. 

Size Choose or type in the font size for the PDF field. If the Auto is selected, the font size 
will be adjusted automatically to fit the field. 

Read Only Check the box if user is not allowed to edit the contents of the PDF field. 

Required Check the box to indicate this PDF field is required and has to be filled in when user 
submits the form. The PDF viewer will prompt the user to fill in the field before  the 
form can be successfully submitted. 

Form Field Is Specify the visibility of the PDF field. 

Orientation Specify the orientation of the PDF field. 

Options tab 

Button/Section Description 

Highlight Mode 
Set the visual effect for the button when user clicks on it. 

None The appearant of the button does not 
change. 

Invert Invert the color of the button. 

Outline Display an outline. 

Push Display as a 3D button. 
 

Normal The text on the button when the button is released. 

Rollover The text on the button when the mouse hovers over the button. 

Pushed The text on the button when the button is pressed 

Actions tab 

Button/Section Description 

Trigger 
List of events to trigger the actions defined in the Action list on its right: 

Mouse Up Release left mouse button on the PDF 
field 

Mouse Down Press left mouse button on the PDF field 
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Button/Section Description 

Mouse Enter Mouse cursor enters the PDF field 

Mouse Exit Mouse cursor exits the PDF field 

On Focus The PDF field receives input focus 

On Blur Input focus is lost from the PDF field 
 

Action You can define a list of actions for any trigger event listed in the Trigger box. When 
a trigger event occurs, the associated actions defined in this box will be executed 
sequentially. You can use Add, Edit, Delete, Up, Down button to modify the 
action list. 

Add Add an action for the selected trigger. The Action Properties dialog box will pop up. 

Edit Edit the selected action. The Action Properties dialog box will pop up. 

Delete Delete the selected action. 

Up Move the selected action up in the list. 

Down Move the selected action down in the list. 

See also 
Action Properties dialog box 

Signature Box Properties dialog box 

This dialog box allows user to set or change properties of the selected PDF signature box in the active document. You can bring up 
this dialog box by choosing Field Properties from the CenoPDF menu with a PDF signature box selected in the document. 

Note: One of the following two conditions must be met in order to allow your end users to use a signature box to sign and save a 
document. 1) Your end users have Adobe Acrobat; or 2) You, the author, have Adobe Acrobat 8 or higher and used Enable 
Usage Right in Adobe Reader command on the CenoPDF-generated PDF. 

Button/Section Description 

Name Name of the signature box. The name cannot be empty. 

Short Description A brief description of the signature box. 

Appearance tab 

Button/Section Description 

Border Color If this box is checked, the border color of the PDF field is enabled and you can pick 
a color by clicking the button next to it; Otherwise, the border of the field is not 
drawn. 

Background Color If this box is checked, the background color of the PDF field is enabled and you can 
pick a color by clicking the button next to it; Otherwise, the background of the field 
is not drawn. 

Width Choose the border width of the PDF field. 

Style Choose the border style of the PDF field. 

Text Color Choose text color for the PDF field by clicking the button. 

Font Choose the font for the PDF field. Note that the first 14 fonts are PDF built-in fonts. 
All the other ones are the fonts installed on your Windows system. 
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Button/Section Description 

Size Choose or type in the font size for the PDF field. If the Auto is selected, the font size 
will be adjusted automatically to fit the field. 

Read Only Check the box if user is not allowed to edit the contents of the PDF field. 

Required Check the box to indicate this PDF field is required and has to be filled in when user 
submits the form. The PDF viewer will prompt the user to fill in the field before  the 
form can be successfully submitted. 

Form Field Is Specify the visibility of the PDF field. 

Orientation Specify the orientation of the PDF field. 

Actions tab 

Button/Section Description 

Trigger 
List of events to trigger the actions defined in the Action list on its right: 

Mouse Up Release left mouse button on the PDF 
field 

Mouse Down Press left mouse button on the PDF field 

Mouse Enter Mouse cursor enters the PDF field 

Mouse Exit Mouse cursor exits the PDF field 

On Focus The PDF field receives input focus 

On Blur Input focus is lost from the PDF field 
 

Action You can define a list of actions for any trigger event listed in the Trigger box. When 
a trigger event occurs, the associated actions defined in this box will be executed 
sequentially. You can use Add, Edit, Delete, Up, Down button to modify the 
action list. 

Add Add an action for the selected trigger. The Action Properties dialog box will pop up. 

Edit Edit the selected action. The Action Properties dialog box will pop up. 

Delete Delete the selected action. 

Up Move the selected action up in the list. 

Down Move the selected action down in the list. 

See also 
Action Properties dialog box 

Advanced tab 

This tab sets the JavaScript to format and validate the PDF field when certain events occur. See Adobe Acrobat online help for more 
information about JavaScript programming.  

Button/Section Description 

Trigger 
List of events to trigger the JavaScript: 

Keystroke When a key is pressed 

Format When the PDF viewer formats the field 

Validate When the PDF viewer validates the contents of the 
field 
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Button/Section Description 

Calculate When the PDF viewer calculates the contents of the 
field 

 

Execute the JavaScript 
Add JavaScript scripts that are to be executed when the selected trigger event occurs. 

Note: If you input keystroke or format script here, the format settings (set in another tab) of the 
field will be ignored. 

Free Text Properties dialog box 

This dialog box allows user to set or change properties of the selected PDF free text annotation in the active document. You can 
bring up this dialog box by choosing Field Properties from the CenoPDF menu while a PDF free text annotation is selected. 

Button/Section Description 

Font The font to display the annotation. 

Size Size of the font to display the annotation. 

Align The alignment of the annotation. 

Contents The contents of the annotation. 

Thickness The thickness of the border of the annotation. 

Fill Color If the box is checked, the background color of the annotation is enabled. You can 
choose a background color by clicking the button next to it. 

Border Color Color of the annotation border. You can choose a color by clicking the button next to 
it. 

Author The author name of the annotation. 

Modified The last time when the annotation is modified. 

Link Properties dialog box 

This dialog box allows user to set or change properties of the selected PDF link in the active document. You can bring up this dialog 
box by choosing Field Properties from the CenoPDF menu while a PDF link is selected. 

Button/Section Description 

Type Set if the border of the link is visible. 

Highlight Set how the link is displayed when user clicks on it. 

Width The width of the border. 

Color The color of the border. 

Style The line style of the border. 

Action The list of actions will be executed when the link is clicked. 

Add Add a new action to the list. 

Edit Edit the selected action from the list. 

Delete Delete the selected action from the list. 
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Button/Section Description 

Up Move the selected action up in the list. 

Down Move the selected action down in the list. 

Markup Properties dialog box 

This dialog box allows user to set or change properties of the selected PDF markup annotation in the active document. You can 
bring up this dialog box by choosing Field Properties from the CenoPDF menu while a PDF markup annotation is selected. 

Button/Section Description 

Type Set how the markup annotation will be displayed. The type can be Highlight, 
Underline, Squiggly or Strike Out. 

Color The color of the markup annotation. 

Offset X The offset X coordinate of the popup window relative to the left-top corner of the 
annotation. 

Offset Y The offset Y coordinate of the popup window relative to the left-top corner of the 
annotation. 

Width The width of the popup window. 

Height The height of the popup window. 

Note The contents of the popup window. 

Author The author name of the annotation. 

Modified The last time when the annotation is modified. 

Note Properties dialog box 

This dialog box allows user to set or change properties of the selected PDF note in the active document. You can bring up this 
dialog box by choosing Field Properties from the CenoPDF menu while a PDF note is selected. 

Button/Section Description 

Icon The icon of the note. 

Color The color of the note. 

Offset X The offset X coordinate of the popup window relatitve to the left-top corner of the 
icon. 

Offset Y The offset Y coordinate of the popup window relative to the left-top corner of the 
icon. 

Width The width of the popup window. 

Height The height of the popup window. 

Note The contents of the popup window. 

Author The author name of the note. 

Modified The last time when the note is modified. 
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Square Shape Properties dialog box 

This dialog box allows user to set or change properties of the selected PDF square shape annotation in the active document. You 
can bring up this dialog box by choosing the Field Properties from the CenoPDF menu with a PDF square shape annotation 
selected. 

Button/Section Description 

Square The annotation will be displayed as a square. 

Circle The annotation will be displayed as a circle. 

Thickness The thickness of the border of the annotation. 

Fill Color If the box is checked, the background color of the annotation is enabled. You can 
choose the background color by clicking the button next to it. 

Border Color Color of the annotation border. You can choose a color by clicking the button next to 
it. 

Offset X The offset X coordinate of the popup window relative to the left-top corner of the 
annotation. 

Offset Y The offset Y coordinate of the popup window relative to the left-top corner of the 
annotation. 

Width The width of the popup window. 

Height The height of the popup window. 

Note The contents in the popup window. 

Author The author name of the annotation. 

Modified The last time the annotation is modified. 

PDF Page Properties dialog box 

This dialog box allows users to set or change properties of the selected PDF page settings field in the active document. You can 
bring up this dialog box by choosing Field Properties from the CenoPDF menu while a PDF page settings field is selected. 

Button/Section Description 

Trigger 
List of events to trigger the actions: 

Open Page Execute the actions when the page is 
opened. 

Close Page Execute the actions when the page is closed. 
 

Action The list of actions will be executed when the selected trigger event occurs. 

Add Add a new action to the list. 

Edit Edit the selected action from the list. 

Delete Delete the selected action from the list. 

Up Move the selected action up in the list. 

Down Move the selected action down in the list. 
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Document settings dialog box 

Choose Document Settings from the CenoPDF menu to bring up this dialog box. It allows user to set document-level PDF 
settings for the active document.  

Summary tab 

Button/Section Description 

Title The title of the PDF file. 

Subject The subject of the PDF file. 

Author The author of the PDF file. 

Keywords The keywords for the PDF file. 

Document Actions tab 

Button/Section Description 

Trigger 
List of events to trigger the JavaScript: 

Close When the PDF file is closed 

Before Save Before the PDF file is saved 

After Save After the PDF file is saved 

Before Print Before the PDF file is 
printed 

After Print After the PDF file is printed 
 

Execute the JavaScript Add in the JavaScript that will be executed when the selected trigger event occurs. 

Document Level JavaScript tab 

Button/Section Description 

Name List of script names for the document level JavaScript. 

JavaScript The JavaScript associated with the selected script name. 

Add Add a new script. 

Delete Delete the selected script. 

Field Manager dialog box 

Choose Field Manager from the CenoPDF menu to bring up this dialog box. It lists all the PDF fields from the active document. 
You can select one or more fields from the list and execute commands to manipulate the selected items. You can click a column 
header to sort the fields. If you want to set the tab order of the fields, you need to click the Tab Order header, drag and drop the 
items and choose  Set Tab Order from the Edit menu. See Changing tab orders for more information. 

Commands under the Edit menu are as follows: 

Button/Section Description 

Properties Displays the properties dialog box for the selected fields. 

Set Tab Order Applies changes of tab order to the document. After you move the field up or down, 
you must click this button to apply the changes. This command can be used only 
after you click the Tab Order header in the field list. 
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Button/Section Description 

Go To Closes the dialog box, selects the field in the document and scrolls it in to view. 

Set Unique Name If you copy and paste fields in your document, you will create fields with duplicated 
names. This command sets the name of selected fields to be unique. 

Delete Deletes selected fields from the document. 

Show / Hide Shows or hides selected fields in the document. These commands are useful if your 
fields cover some texts. 

Selected All Selects all listed fields. 

See also 
Changing tab orders 

Action Properties dialog box 

This dialog box allows user to set or change the properties of an action. You can bring up this dialog box when you add an action or 
edit an existing action from a PDF field properties dialog box. You can use Action Type dropdown list to select an action. 
Then the remaining part of the dialog box will show available options accordingly.  

Email Form Data action 

When this action is triggered, PDF viewer will open user's email client and populate email body according to a pre-set template. 

Go To View action 

When this action is triggered, PDF viewer will display the specified destination page. 

Button/Section Description 

The destination is in this file. The destination is in the PDF file exported from the current document. 

The destination is in the specified file. Click the Select File button to select a destination PDF file. 

Page Number The page number of the destination page in the specified file. 

Magnification 
Specify how the destination page is displayed. 

 Type Specify how the destination page is aligned or zoomed. 

 Left, Right, Top and Bottom Location or alignment position of the 
destination page when it is displayed. 

 Zoom Zoom factor when the destination page is displayed. 

JavaScript action 

When this action is triggered, PDF viewer will execute the specified JavaScript. 

Show or Hide Fields action 

When this action is triggered, PDF viewer will show or hide the specified fields. Click the check box next to field names to select or 
unselect a field. 

Import Form Data action 

When this action is triggered, PDF viewer will import data from the specified FDF file to fill the fields in the current PDF file. For 
information about FDF file, please refer to the Adobe Acrobat documentation. 
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Open File action 

When this action is triggered, PDF viewer will open the specified file. 

Go To Named Page action 

When this action is triggered, PDF viewer will display the page specified. 

World Wide Web Link action 

When this action is triggered, PDF viewer will open a browser and display the specified web page. 

Reset Form action 

When this action is triggered, PDF viewer will reset the value of selected fields. 

Submit Form action 

When this action is triggered, PDF viewer will submit the form data to the specified server. This feature is mostly for software 
developer. Please refer to any client-server development material for more information.  

Print Form action 

When this action is triggered, PDF viewer will bring up the print dialog box and print the document. 

Options dialog box 

This dialog box sets the global settings that will be applied to the software and all PDF files. You can bring up this dialog box by 
choosing Options from the CenoPDF menu. 

General tab 

Button/Section Description 

Use Microsoft Export as 
PDF add-in if it is 
installed in Office 2007 

This check box controls which PDF engine you want to use. If you use Microsoft Office 2007 you 
have the option to install the FREE Microsoft Export as PDF add-in, which can be downloaded from 
http://www.microsoft.com. This check box will be enabled once it is installed. 

If you use Microsoft Office 2003 or earlier version, or you do not install the Microsoft Export as PDF 
add-in, or you uncheck this check box, you will use the built-in engine shipped with CenoPDF. 

Note: Even if you installed Microsoft Export as PDF add-in, you still need to use the command 
CenoPDF > Export as PDF to create fillable PDF forms. 

Export what Document Generates PDF files without any markups. 
Document 
showing 
markup 

Generates PDF files with markups such as Microsoft Word comments, etc. If this 
option is selected, PDF fields may be misaligned in the generated files. 

 

Always use property grid 
to edit field properties  

By default, if only one field is selected, CenoPDF uses regular dialog boxes to edit its properties; if 
multiple fields are selected, it uses property grid to edit the properties. If this box is checked, 
CenoPDF will use property grid in all conditions. 

Defaults tab 

This tab allows you to set default settings for all fields. When you insert a new field into document, CenoPDF will use settings here. 

Button/Section Description 
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Button/Section Description 

Change Default Settings Show the dialog box to edit the default settings of the selected field type. 

Restore All Factory Defaults Restore default settings for all field types to factory defaults. The button clears 
all changes you made in this tab. 

Adobe Viewer tab 

Options in this tab are available if you use CenoPDF built-in PDF engine 

Button/Section Description 

Start page Sets the page that will be first shown when opening the PDF file. By default, the first 
page will be shown. 

Page layout You can choose form next page layouts: Single Page, Continuous, Facing and 
Continuous - Facing. By default the PDF file will be opened with the Continuous 
page layout. 

Show You can choose to show some viewer panels when PDF file is opened: Pages 
Panel, Bookmarks Panel, Layers Panel, Attachments Panel. You can also 
choose to show the PDF file in the Full Screen mode. By default the PDF file will be 
opened without any panel, show Page Only mode. 

Compression tab 

Options in this tab are available if you use CenoPDF built-in PDF engine 

Button/Section Description 

Text and graphics   

Enable compression If checked text and graphics will be compressed. 

Method Text and graphics will be compressed using ZIP compression. 

Level Available compression levels are: Fastest, Normal and Maximum. By default, 
Normal level of compression is used. 

High color images   

Enable compression If checked high color images will be compressed. 

Method High color images will be compressed using JPEG or ZIP compression. 

Level You can choose ZIP compression level from Fastest, Normal and Maximum, and 
JPEG compression level from Minimum, Low, Medium, High and Maximum. By 
default, the high color images will be compressed with the High level of JPEG 
compression. 

Indexed and monochrome images   

Enable compression If checked indexed and monochrome images will be compressed. 

Method Only ZIP compression is available to this type of images. 

Level Available compression levels are: Fastest, Normal and Maximum. By default, 
Normal level of compression is used. 

Enable optimization of image 
sequences 

When this option is enabled, small image sequences are combined in one big image. 
The process time will be slightly increased but the resulting PDF file will be smaller. 
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Button/Section Description 

You should enable this option if you have many sequences of small monochrome 
images and your resulting PDF file is very large. By default, this option is not 
enabled. 

Fonts tab 

Options in this tab are available if you use CenoPDF built-in PDF engine 

This tab allows you to choose which fonts will be embedded or not in the resulting PDF file. 

Button/Section Description 

Embed font subsets You can choose to embed only subsets of font files by checking the Embed Font 
Subsets check box. This will generate smaller PDF files, so this setting is enabled 
by default. When using characters that are not in the standard Latin character set 
(eastern European character set, Japanese, Chinese, Korean or other character sets) 
the font subset is included in the PDF file, no matter if the font subsets checkbox is 
set or not, because otherwise these characters will not be included in the generated 
PDF files. 

Embed all used fonts You can choose to embed all fonts that are used in a PDF file by checking the 
Embed All Used Fonts check box. This will generate bigger PDF files, so this 
setting is not recommended, unless you have to open the generated PDF files on a 
computer that does not have all used fonts installed. 

Available fonts The available fonts list shows all TrueType and OpenType fonts installed on your 
computer that are not already listed in the Always embed fonts and Never 
embed fonts lists. You can select multiple items from the list and move them using 
the right arrow button from the form. 

Always embed fonts Once checked, this option will allow you to embed all fonts from the list below into 
the PDF file. The list can be filled from the Available fonts list using the right 
arrow button. You can select multiple items from the list and remove them using the 
left arrow button from the form. 

Never embed fonts Once checked, this option will prevent embedding of the fonts from the list below 
into the PDF file. The list can be filled from the Available fonts list using the right 
arrow button. You can select multiple items from the list and remove them using the 
left arrow button from the form. By default, the Arial, Courier and Times New 
Roman fonts are in the Never Embed Fonts list because they are standard fonts in 
the PDF format and they do not need to be embedded with the PDF file. 

Move buttons The buttons are enabled only if items are selected in the fonts lists. Pressing these 
button results in the selected items being removed from the originating list and 
added to the destination list. 

 Microsoft Export as PDF tab 

Options in this tab are available if you use Microsoft Export as PDF add-in. Note: even if you installed Microsoft Export as PDF add-
in, you still need to use the command CenoPDF > Export as PDF to create fillable PDF forms. 

Button/Section Description 

Optimize the PDF file for Specifies how to optimize your PDF. Available options are Standard, Print, Minimum File 
Size, Commercial. The default option is Standard. 

Down-sample color images   

Enable If this box is checked, while a color image's resolution exceeds the threshold it will be sampled 
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Button/Section Description 

to the target resolution. 

Target Sets the target resolution to sample to. 

Threshold Sets the threshold resolution. If an image's resolution exceeds the value here, it will be 
sampled to the target resolution. 

Down-sample black and while 
images 

  

Enable If this box is checked, while a black and white image's resolution exceeds the threshold it will 
be sampled to the target resolution. 

Target Sets the target resolution to sample to. 

Threshold Sets the threshold resolution. If an image's resolution exceeds the value here, it will be 
sampled to the target resolution. 

Export bookmark using No bookmark Does not generate any bookmark in PDF. 
Headings Uses Microsoft Word headings, such as Heading 1, Heading 2, etc. to 

generate bookmarks in PDF. 
Word bookmarks Uses Microsoft Word bookmarks to generate bookmarks in PDF. 

 

Export to PDF from Database dialog box 

Button/Section Description 

Connection String The connection string for the database that contains a table, which will be used to populate the fields in a 
PDF form template. 

Table Name 
The database table name that is used to populate the fields in a PDF form template. If a column name in 
the table is in the format of fieldname_propertyname or fieldname_propertyname_index, each row of data 
of that column will be used to set the property (specified by propertyname) of a PDF field (specified by 
fieldname).  

For radio buttons, because more than one buttons can have the same name, you need to append an index 
number specify which button you want to operate, f or example, color_ExportValue_0. The index is zero 
based and it is same as tab order in the same group of radio buttons. 

If you use an Excel spreadsheet as database, the table name has to be the sheet name plus a $, for 
example, Sheet1$. 

Test This button is used to test database connectivity. After you specify the Connection String and Table 
Name, click this button. It should populate the Database Contents grid. 

Output PDF File 
Path Pattern In the database table, each row of data will generate a PDF file. This box specifies the name of generated 

PDF files. Any text in a bracket will be treated as a token and will be replaced by real data from database 
when generating files. 

If a token matches a database column name, the data of that column will replace the token. For example: 
c:\output\[username].pdf will use the data in database column username to replace the token. 

Otherwise if a token matches any pre-defined tokens below it will be replaced accordingly: 

[count] The number of the PDF file generated. 

[dddd] Week of the day in long format, for example Thursday. 

[ddd] Week of the day in short format, for example Thu. 

[dd] Day of the month, for example 30. 

[MMMM] Month name in long format, for example August. 

[MMM] Month name in short format, for example Aug. 
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Button/Section Description 

[MM] Two-digit month, for example 08. 

[M] Month number, for example 8. 

[yyyy] Four-digit year, for example 2007. 

[yy] Two-digit year, for example 07. 
 

See also 
Exporting to PDF from a database 

Property grid dialog box 

Select multiple fields and choose Field Properties from the CenoPDF menu to bring up this dialog box. If Always use property 
grid to edit field properties box in the Options dialog box General tab is checked, this dialog box is always used even if you 
edit a single field. 

This dialog box lists all properties in a grid. If multiple fields are selected, the grid displays properties shared by all fields and the 
change applies to them all at once. 

Tip: You can see a brief description at the bottom of the grid when you click the name of a property. 

See also 
Options dialog box 

General troubleshooting steps  

1. Close all the other applications before installing CenoPDF.  
If the installer keeps telling you that Microsoft Word is running, but you do not see its window, you should reboot your 
computer, then run the installation again.  

2. Check if you are using the latest version of CenoPDF.  
Launch Microsoft Word and go to CenoPDF > Check for Update or go to CenoPDF > About CenoPDF to compare the 
version and build number to those on our download page. Make sure you download and install the latest version of the 
software before contacting us.  

3. Check if all the latest service packs have been installed.  
For example, Windows XP Service Pack 2 and Office 2003 Service Pack 2.  

4. If your CenoPDF used to work before, but suddenly stops working now, try these steps. 

5. Enable the logging feature.  
If the installation is successful, but you still have problems running CenoPDF, you can enable the logging feature and email 
us the log file so that we can further help you.  

CenoPDF failed to start up 

Here are troubleshooting steps if Microsoft Word fails to load CenoPDF.  

1. Check if CenoPDF add-in is disabled in Word. Launch Microsoft Word. If you use Word 2003 or earlier, choose Help > 
About Microsoft Office Word > Disabled Items. If CenoPDF or OffbatShim.Connect is listed in this box, enable it 
and restart Word. 

http://www.lystech.com/download-pdf-form-tool.aspx
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If you use Word 2007, you should click Office button at left top corner, then Word Options. Click Add-ins. If CenoPDF 
or OffbatShim.Connect is listed as disabled (see screenshot below), use the Go button to enable it, then restart Word. 
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2. Continue if above step does not work. 

3. Go to Control Panel > Add / Remove Program. Uninstall the following items: 

 CenoPDF 

 Shared Add-in Extensibility Update for Microsoft .NET Framework 2.0 (KB908002) 

 Shared Add-in Support Update for Microsoft .NET Framework 2.0 (KB908002) 
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4. Download and install the latest version of CenoPDF in case if you do not have. 

5. From the Start menu on desktop, choose All Programs > CenoPDF > Add-in Manager. 

6. In Add-in Manager, check Reset CenoPDFand Delete Normal.dot boxes. Click the OK button. 

Note if you have changed Normal.dot template before and want to keep its contents, you must back up the file and 
restore them later. This file will be deleted after you click the OK button. 
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7. Launch Microsoft Word. See if CenoPDF works. 

8. Keep in mind that Microsoft Word will not load CenoPDF if anyof the following three items is not set correctly. Double-check 
them if CenoPDF is not loaded. 

 Shared Add-in Support Update (KB908002) must be successfully installed. 

 Microsoft Word must be checked in Add-in Selector. 

 CenoPDF or OffbatShim.Connect must not be listed in Word as disable add-in. 

9. Input your registration code again if you have it. 

10. If CenoPDF can be loaded by Microsoft Word but still does not work correctly usually you will see some error messages. 
Send us those error messages for further troubleshooting. 

Generating log file 

In order to provide more information for us to troubleshoot, you can enable CenoPDF's logging feature. 

To enable the logging feature, go to CenoPDF installation directory, which, by default, is located at C:\Program Files\Lystech 
Computing\CenoPDF. Open the Addin.config file in a text editor. Change the value of Level to ALL and save the file. Next 
time when you restart Microsoft Word or Microsoft Publisher, the logging feature will be in effect, which will generate a log file at 
C:\CenoPDFLog\Log.txt if any problem occurs. Email us the log file so that we can further help you. 

Using MSI file to install 

Enterprise administrator may want to install CenoPDF silently or skip the prerequisite files, such as novaPDF or .NET add-in update. 
Doing that you will need to extract the MSI file from the installation executable as follows. You must have Microsoft .NET 
Framework 2.0 installed before installing the msi file. 

1. Install CenoPDF normally. 

2. The MSI file will be extracted to the system temporary folder %temp%\CenoPDFExtract. The file name is 
CenoPDFSetup.msi. The two prerequisites are also under the sub folder KB908002 and novaPDF.  

After getting the MSI file, you can create your own installer. 

 If you run 

CenoPDFSetup.msi  

the prerequisites won't be installed. 
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 if you run 

CenoPDFSetup.msi /q  

the installation will go silently. 

  


